{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:930ee389-de10-51ef-a83d-7a157452913c",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "elasticsearch-plugin-classloader",
      "purl": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1",
      "type": "library",
      "group": "org.elasticsearch",
      "bom-ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1",
      "version": "7.17.15-tuxcare.1",
      "pedigree": {
        "ancestors": [
          {
            "name": "elasticsearch-plugin-classloader",
            "purl": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15",
            "type": "library",
            "group": "org.elasticsearch",
            "version": "7.17.15"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2023-49921",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:2b13b428-a646-5f01-9078-ba43325a1494",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2023-49921 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-23444",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:c160579e-ee61-5a83-87d5-2f9c4367ad14",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-23444 is fixed in version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-23446",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:989cdcff-db70-541e-89d3-bafb2f7d61cb",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-23446 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-23450",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:aaf32254-96e0-5d3b-ae5d-ed162d2ea0cd",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-23450 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-43709",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:1f682e39-7faf-5e0f-b7a2-9345546840e5",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-43709 is fixed in version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-52979",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:2ab0210c-d3d3-5f7f-9910-d64aaf8bc9b1",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-52979 is fixed in version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-52980",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:07d2a4be-09bd-58fc-8077-f6dfdda5776d",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-52980 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2024-52981",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:31516d28-211b-539f-9169-51dbeedcb9cd",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2024-52981 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2025-37727",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:fccdc8ec-22e8-5de6-9485-e2068b39afc2",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2025-37727 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2025-37731",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:7cd96447-e5d7-57ae-89a5-96c16b5357ca",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2025-37731 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    },
    {
      "id": "CVE-2025-68384",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:094e7d3d-84fc-552c-b69c-8569eb0d8158",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2025-68384 does not affect version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader. not_affected \u2014 Elasticsearch 7.17.15 does not contain the User Profile feature (ProfileService) that is affected by CVE-2025-68384. The vendor patches add size validation to ProfileService.updateProfileData(), which stores user profile labels and applicationData. This entire feature was introduced in Elasticsearch 8.2+ and is completely absent from the 7.x series. Exhaustive searches confirm no ProfileService...",
        "justification": "code_not_present"
      }
    },
    {
      "id": "CVE-2025-68390",
      "affects": [
        {
          "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
        }
      ],
      "bom-ref": "urn:uuid:fec4b4c2-bba4-5750-abfc-e13f700fc45d",
      "analysis": {
        "state": "exploitable",
        "detail": "Vulnerability CVE-2025-68390 affects version 7.17.15-tuxcare.1 of org.elasticsearch:elasticsearch-plugin-classloader."
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:maven/org.elasticsearch/elasticsearch-plugin-classloader@7.17.15-tuxcare.1"
    }
  ]
}