{
  "$schema": "http://cyclonedx.org/schema/bom-1.6.schema.json",
  "bomFormat": "CycloneDX",
  "specVersion": "1.6",
  "serialNumber": "urn:uuid:12c444ad-2519-5514-b1ec-f287e96bd5ad",
  "version": 1,
  "metadata": {
    "supplier": {
      "name": "TuxCare",
      "url": [
        "https://tuxcare.com"
      ]
    }
  },
  "components": [
    {
      "name": "express",
      "purl": "pkg:npm/express@3.21.2-tuxcare.5",
      "type": "library",
      "bom-ref": "pkg:npm/express@3.21.2-tuxcare.5",
      "version": "3.21.2-tuxcare.5",
      "pedigree": {
        "ancestors": [
          {
            "name": "express",
            "purl": "pkg:npm/express@3.21.2",
            "type": "library",
            "version": "3.21.2"
          }
        ]
      },
      "supplier": {
        "url": [
          "https://tuxcare.com"
        ],
        "name": "TuxCare"
      }
    }
  ],
  "vulnerabilities": [
    {
      "id": "CVE-2024-10491",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:7c487d29-3ffa-5919-b10c-de94b9a9b01b",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-10491 is fixed in version 3.21.2-tuxcare.5 of express."
      }
    },
    {
      "id": "CVE-2024-29041",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:cd810d57-dbaa-55ef-8015-adb5c1353363",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-29041 is fixed in version 3.21.2-tuxcare.5 of express."
      }
    },
    {
      "id": "CVE-2024-43796",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:7bbdd98f-e2cc-5f51-9ea4-8b35e120c682",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-43796 is fixed in version 3.21.2-tuxcare.5 of express."
      }
    },
    {
      "id": "CVE-2024-51999",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:506ffce9-afaf-5b0b-bf29-830729828a28",
      "analysis": {
        "state": "false_positive",
        "detail": "Vulnerability CVE-2024-51999 is a false positive for express 3.21.2-tuxcare.5."
      }
    },
    {
      "id": "CVE-2024-9266",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:52488488-d6a6-5a8d-a169-41ee5751da9a",
      "analysis": {
        "state": "resolved",
        "detail": "Vulnerability CVE-2024-9266 is fixed in version 3.21.2-tuxcare.5 of express."
      }
    },
    {
      "id": "CVE-2026-2391",
      "affects": [
        {
          "ref": "pkg:npm/express@3.21.2-tuxcare.5"
        }
      ],
      "bom-ref": "urn:uuid:27976da7-e5da-5878-ad00-84a40e36b165",
      "analysis": {
        "state": "not_affected",
        "detail": "Vulnerability CVE-2026-2391 does not affect version 3.21.2-tuxcare.5 of express. not_affected \u2014 Express 3.21.2 does not contain the vulnerable code. The CVE-2026-2391 vulnerability exists in the `qs` library (versions < 6.14.2), not in Express's source code. Express 3.21.2 delegates query parsing to Connect middleware and does not vendor or bundle the `qs` library code. The vulnerability pattern (arrayLimit bypass in comma parsing) is not present in the Express repository.",
        "justification": "requires_dependency"
      }
    }
  ],
  "dependencies": [
    {
      "ref": "pkg:npm/express@3.21.2-tuxcare.5"
    }
  ]
}