{
  "@id": "urn:uuid:c691ed59-8e1b-4407-8c32-f8c9a26d0d4c",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 1,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-21T15:09:40.979519+00:00",
  "statements": [
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-21T15:09:40.979519+00:00",
      "status_notes": "Vulnerability CVE-2026-22752 is fixed in version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-22752"
      }
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-21T15:09:40.979519+00:00",
      "status_notes": "Vulnerability CVE-2026-41008 does not affect version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server. not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-41008"
      },
      "impact_statement": "not_affected \u2014 Spring Authorization Server version 1.4.8 is NOT AFFECTED by CVE-2026-41008. The vulnerability requires request_uri parameter handling (OAuth 2.0 Pushed Authorization Requests / PAR feature), which was introduced in version 1.5.0 (March 2025). Version 1.4.8 predates this feature entirely. The specific attack chain described in the CVE\u2014crafting a request with invalid request_uri and arbitrary re..."
    },
    {
      "status": "affected",
      "products": [
        {
          "@id": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2",
          "identifiers": {
            "purl": "pkg:maven/org.springframework.security/spring-security-oauth2-authorization-server@1.4.8-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-21T15:09:40.979519+00:00",
      "status_notes": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server.",
      "vulnerability": {
        "name": "CVE-2026-59316"
      },
      "action_statement": "Vulnerability CVE-2026-59316 affects version 1.4.8-tuxcare.2 of org.springframework.security:spring-security-oauth2-authorization-server."
    }
  ]
}
